Tag Archives: 1965

’65 Malibu Station Wagon

[zfp_photo id=’h21d26ca4′]

Would you have guessed it? Yep, I spied another Wagon at the Todd Harding and Son Phoenix Car Swap Meet, well not AT the swap meet but in the parking lot. The body and paint on this thing were in great shape and I could tell the owner wanted to keep it that way since he parked about as far away as he could from the rest of the patrons. I was grateful because I ended up with some nice shots of it. More shots after the jump. Continue reading

’65 Acadian Station Wagon

[zfp_photo id=’h280b97b8′]

Ever heard of an Acadian? I know that I hadn’t, basically it is the Great White North’s version of the Chevy II/Nova. There were quite a few Canadians at the show that brought out their beautiful classics and was glad that I hunted the cars down in the parking lot. More shots after the jump! Continue reading

Ringbrothers Blizzard ’65 Mustang – SEMA 2013

Please try entering https://graph.facebook.com/232044070290553/photos?fields=source,link,name,images,album&limit=200 into your URL bar and seeing if the page loads.

I have been a fan of Ringbrothers since I saw a few of their builds at the Goodguys Rod & Custom Association Southwest nationals a few years back. I was stoked to see a few more of their buildsThe SEMA Show 2013 and was really looking forward to seeing this build. At the heart of this beast is a 427ci Nascar motor putting 710 ponies down inhaling through a Holly Carb and exhaling through Flowmaster Exhaust. HRE Performance Wheels(570R) and Nitto Tire (Invo) grapple with the power while Baer Brakes 6-piston calipers bring it all to a halt. In their typical style, Ringbrothers poured attention into every detail in every area you can see. Keep Standing Apart Fellas! Thanks for hosting them in your booth GFS – Global Finishing Solutions#SEMA2013,#Ringbrothers#GFS#Blizzard#65Mustang#Nitto#HRE,#Baer

Facebook API came back with a faulty result. You may be accessing an album you do not have permissions to access.

’65 Mustang Wagon

Please try entering https://graph.facebook.com/218197831675177/photos?fields=source,link,name,images,album&limit=200 into your URL bar and seeing if the page loads.

The wagon that never was, I know that some people will call this an abomination but I personally dig it!
Facebook API came back with a faulty result. You may be accessing an album you do not have permissions to access.